Home30 Days Of CodeHackerrank Day 8 : Dictionaries and Maps 30 days of code solution

Hackerrank Day 8 : Dictionaries and Maps 30 days of code solution

In this Hackerrank Day 8 : Dictionaries and Maps 30 days of code solution we’re learning about Key-Value pair mappings using a Map or Dictionary data structure. 

Task

Given n names and phone numbers, assemble a phone book that maps friends’ names to their respective phone numbers. You will then be given an unknown number of names to query your phone book for. For each name queried, print the associated entry from your phone book on a new line in the form name=phoneNumber; if an entry for name is not found, print Not found instead.

Note: Your phone book should be a Dictionary/Map/HashMap data structure.

Input Format

The first line contains an integer, n, denoting the number of entries in the phone book.
Each of the n subsequent lines describes an entry in the form of 2 space-separated values on a single line. The first value is a friend’s name, and the second value is an 8-digit phone number.

After the n lines of phone book entries, there are an unknown number of lines of queries. Each line (query) contains a name to look up, and you must continue reading lines until there is no more input.

Note: Names consist of lowercase English alphabetic letters and are first names only.

Constraints

  • 1 <= n <= 105
  • 1 <= queries <= 105

Output Format

On a new line for each query, print Not found if the name has no corresponding entry in the phone book; otherwise, print the full name and phoneNumber in the format name=phoneNumber.

Sample Input

3
sam 99912222
tom 11122222
harry 12299933
sam
edward
harry

Sample Output

sam=99912222
Not found
harry=12299933

Explanation

We add the following n = 3 (Key,Value) pairs to our map so it looks like this:

phoneBook = {(sam, 99912222), (tom, 11122222), (harry, 12299933)}

We then process each query and print key=value if the queried key is found in the map; otherwise, we print Not found.

Query 0: sam
Sam is one of the keys in our dictionary, so we print sam=99912222.

Query 1: edward
Edward is not one of the keys in our dictionary, so we print Not found.

Query 2: harry
Harry is one of the keys in our dictionary, so we print harry=12299933.


Hackerrank Day 8 : Dictionaries and Maps 30 days of code solution

Dictionaries and Maps HackerRank Solution in C

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <strings.h>

typedef struct pair {
	char* first;
	char* second;
	struct pair* next;
} pair;

typedef struct dict {
	int size;
	pair** table;
} dict;

unsigned int hash(char* s) {
	unsigned int hashval = 1337;
	for (int i=0; i<(int)strlen(s); i++) {
		hashval = hashval * s[i] + 0xdeadbeef;
		hashval %= 0x3f3f3f3f;
	}
	return hashval;
}

void setsize(dict* d, int s) {
	d->table = malloc(s * sizeof(pair*));
	d->size = s;
	bzero(d->table, s * sizeof(pair*));
}

void insert(dict* d, char* k, char* v) {
	pair* p = malloc(sizeof(pair));

	char* s = malloc(strlen(k) * sizeof(char) + 1);
	char* t = malloc(strlen(v) * sizeof(char) + 1);
	strcpy(s, k);
	strcpy(t, v);

	p->first = s;
	p->second = t;
	p->next = NULL;

	unsigned int hashval = hash(k);
	if (d->table[hashval % d->size] == NULL)
		d->table[hashval % d->size] = p;
	else {
		pair* q = d->table[hashval % d->size];
		while (q->next)
			q = q->next;
		q->next = p;
	}
}

char* retreive(dict* d, char* k) {
	unsigned int hashval = hash(k);
	pair* p = d->table[hashval % d->size];

	if (!p) return NULL;

	while (strcmp(p->first, k) != 0) {
		if (p->next) p = p->next;
		else return NULL;
	}

	return p->second;
}

int main(void) {
	dict* d = malloc(sizeof(dict));
	setsize(d, 10000007);

	int T;
	scanf("%d", &T);

	char s[37];
	char t[37];
	while(T--) {
		scanf("%s %s", s, t);
		insert(d, s, t);
	}

	while(scanf("%s", s) != EOF) {
		if (retreive(d, s) != NULL)
			printf("%s=%s\n", s, retreive(d, s));
		else
			printf("Not found\n");
	}

	return 0;
}

Dictionaries and Maps HackerRank Solution in C ++

#include <cmath>
#include <cstdio>
#include <vector>
#include <iostream>
#include <algorithm>
#include <map>
using namespace std;


int main() {
    /* Enter your code here. Read input from STDIN. Print output to STDOUT */   
    string temp;
    getline(cin, temp);
    int N = stoi(temp);
            
    map<string, string> phoneList;
    for(int n = 0; n < N; n++){
        string name;
        string number;
        getline(cin, name);
        getline(cin, number);
        phoneList.insert(std::pair<string, string>(name, number));
    }
    
    string name;
    while(getline(cin, name))
    {
        std::map<string, string>::iterator it;
        it = phoneList.find(name);
        if (it == phoneList.end()){
            cout << "Not found" << endl;
        } else {
            cout << name << "=" << it->second << endl;
        }
    }
    
    return 0;
}

Dictionaries and Maps HackerRank Solution in Java

//Complete this code or write your own from scratch
import java.util.*;
import java.io.*;

class Solution{
    public static void main(String []argh){
        Map<String,Integer> phoneBook = new HashMap<String,Integer>();
        Scanner in = new Scanner(System.in);
        int n = in.nextInt();
        in.nextLine();
        for(int i=0;i<n;i++){
            String name = in.nextLine();
            int phone = Integer.parseInt(in.nextLine());
            phoneBook.put(name, phone);
        }
        while(in.hasNext()){
            String s = in.nextLine();
            Integer phoneNumber = phoneBook.get(s);
            System.out.println(
                (phoneNumber != null) 
                ? s + "=" + phoneNumber 
                : "Not found"
            );
        }
        in.close();
    }
}

Dictionaries and Maps HackerRank Solution in Python 3

# Enter your code here. Read input from STDIN. Print output to STDOUT

x = int(input())

dictt = {}

for i in range(x):
    text = input().split()
    dictt[text[0]] = text[1]

while True:
    try:
        inpt = input()
        if inpt in dictt:
            print(inpt+"="+dictt[inpt])
        else:
            print("Not found")
    except EOFError:
        break

Dictionaries and Maps HackerRank Solution in JavaScript

function processData(input) {
    //Enter your code here
    var input = input.split('\n');
    var numLines = input[0];
    var phoneBook = {};
    
    for (var i = 1; i < numLines*2; i=i+2){
        // 1,2; 3,4; 5,6
        phoneBook[input[i]] = input[i+1];
    }
    
    for (var j = numLines*2 + 1; j < input.length; j++){
        if (input[j] in phoneBook) console.log(input[j] + '=' + phoneBook[input[j]]);
        else console.log('Not found');
    }
} 

process.stdin.resume();
process.stdin.setEncoding("ascii");
_input = "";
process.stdin.on("data", function (input) {
    _input += input;
});

process.stdin.on("end", function () {
   processData(_input);
});

NEXT : Hackerrank Day 9 : Recursion 3 30 days of code solution

30 Days of Code HackerRank Solutions List – Day 0 to Day 29


Read More –

RELATED ARTICLES

LEAVE A REPLY

Please enter your comment!
Please enter your name here

Most Popular

- Advertisment -

Categories