Home30 Days Of CodeHackerRank Day 16 : Exceptions – string to integer 30 days of...

HackerRank Day 16 : Exceptions – string to integer 30 days of code solution

Today we are going to solve HackerRank Day 16 : Exceptions – string to integer 30 days of code solution in CC++ , Java , Python & Javascript.

Objective

Today, we’re getting started with Exceptions by learning how to parse an integer from a string and print a custom error message. 

Task

Read a string, S, and print its integer value; if S cannot be converted to an integer, print Bad String.

Note: You must use the String-to-Integer and exception handling constructs built into your submission language. If you attempt to use loops/conditional statements, you will get a 0 score.

Input Format

A single string, S.

Constraints

  • 1 <= |S| <= 6, where |S| is the length of string S.
  • S is composed of either lowercase letters (a – zor decimal digits (0 – 9).

Output Format

Print the parsed integer value of S, or Bad String if S cannot be converted to an integer.

Sample Input 0

3

Sample Output 0

3

Sample Input 1

za

Sample Output 1

Bad String

Explanation

Sample Case 0 contains an integer, so it should not raise an exception when we attempt to convert it to an integer. Thus, we print the 3.
Sample Case 1 does not contain any integers, so an attempt to convert it to an integer will raise an exception. Thus, our exception handler prints Bad String.


HackerRank Day 16 : Exceptions – string to integer 30 days of code solution

Exceptions – string to integer HackerRank Solution in C++

#include <cmath>
#include <cstdio>
#include <vector>
#include <iostream>
#include <algorithm>
using namespace std;


int main() {
    string s;
    cin >> s;
    
    try {
        cout << stoi(s) << endl;
    } catch(...) {
        cout << "Bad String" << endl;
    }
    
    return 0;
}

Exceptions – string to integer HackerRank Solution in Java

import java.io.*;
import java.util.*;

public class Solution {

    public static void main(String[] args) {
        try(Scanner scan = new Scanner(System.in);){
            int input = Integer.parseInt(scan.nextLine());
            System.out.println(input);
        }
        catch(NumberFormatException e){
            System.out.println("Bad String");
        }
    }
}

Exceptions – string to integer HackerRank Solution in Python 3

#!/bin/python3

import sys


S = input().strip()

try:
    S = int(S)
    print(S)
except:
    print("Bad String")

Exceptions – string to integer HackerRank Solution in Javascript

process.stdin.resume();
process.stdin.setEncoding('ascii');

var input_stdin = "";
var input_stdin_array = "";
var input_currentline = 0;

process.stdin.on('data', function (data) {
    input_stdin += data;
});

process.stdin.on('end', function () {
    input_stdin_array = input_stdin.split("\n");
    main();    
});

function readLine() {
    return input_stdin_array[input_currentline++];
}

/////////////// ignore above this line ////////////////////

function main() {
    var S = readLine();
    
    try {
        var num = parseInt(S) || error;
        console.log(num);
        
    } 
    catch (error) {
        console.log("Bad String");
    }

}


NEXT : Hackerrank Day 17 : More Exceptions 30 days of code solution

30 Days of Code HackerRank Solutions List – Day 0 to Day 29


Read More –

RELATED ARTICLES

LEAVE A REPLY

Please enter your comment!
Please enter your name here

Most Popular

- Advertisment -

Categories